Modify

Erstellt vor 9 Jahren

Geschlossen vor 9 Jahren

#213 closed Fehler/Defekt (fixed)

Aktuelles Neo2 in Ubuntu 10.04 lässt gdm abstürzen

Erstellt von: dennis Verantwortlicher:
Priorität: hoch Meilenstein: Neo Version 2.0
Komponente: Treiber: Linux – Xkbmap Version: 2.0 Final
Stichworte: ubuntu 10.4 Beobachter:

Beschreibung

In Ubuntu 9.10 lief die aktuelle Version von Neo2 für alle Benutzer ohne Probleme.

Nach einem Upgrade auf (oder einer Neuinstallation von) 10.04 führt die Installation der Dateien von http://neo-layout.org/xkb.tgz jedoch bei einigen (aber scheinbar nicht bei allen) Rechnern dazu, dass der GDM (Gnome Display Manager) kein Anmeldefenster anzeigt, sondern stattdessen immer wieder versucht, sich selbst neu zu starten.

Siehe hierzu auch den Thread im Forum der Ubuntu Users.

Anhänge (0)

Änderungshistorie (19)

comment:1 Geändert vor 9 Jahren durch dennis

  • Komponente von unbekannt nach Treiber: Linux – Xkbmap geändert
  • Version von 2.0 BETA nach 2.0 Final geändert

comment:3 Geändert vor 9 Jahren durch knittl

@björn, ich fürchte ja … ich steh mit dem maintainer in kontakt und halte mich informiert wie und ob wir das lösen können. der von dir gelinkte bug hat aber nichts mit diesem ticket zu tun, da das problem erst vor ein paar tagen auftrat – in ubuntu 10.04 sind diese patches von uns noch nicht enthalten.

jetzt nur noch schauen, dass alles vor dem freeze von xkeyboard-config geregelt ist :-$

comment:4 Antwort: Geändert vor 9 Jahren durch Björn Seifert

Ich habe grade mal testweise in der original Ubuntu 10.04-/usr/share/X11/xkb/symbols/de die Tastencodes für x und q vertauscht, also key <AD10> gegen key <AD01> und trotzdem verändert sich die Belegung selbst nach einem Reboot nicht - wird da evtl irgendwo was gecached? Kann ein Ubuntu 10.04-User das mal kurz bei sich versuchen?

Das könnte bedeuten, dass mit dem svn-xkb-Dateien ein inkonsistenter Zustand entsteht (teilweise gecached aber andere Dateinen unpassend dazu verändert) und gdm deshalb nicht mehr startet.

comment:5 als Antwort auf: ↑ 4 ; Antworten: Geändert vor 9 Jahren durch erik

Replying to Björn Seifert:

Ich habe grade mal testweise in der original Ubuntu 10.04-/usr/share/X11/xkb/symbols/de die Tastencodes für x und q vertauscht, also key <AD10> gegen key <AD01> und trotzdem verändert sich die Belegung selbst nach einem Reboot nicht

Ich habe gerade nochmal zwei Systeme installiert: Ein Ubuntu 10.04 32 bit-System und ein Ubuntu 10.04 64 bit-System.

Bei beiden Systemen habe ich bei der Installation Neo als Tastaturbelegung ausgewählt. Außerdem beim Erstellen des Benutzers unten „Automatisch anmelden“ angeklickt.

Nach der Installation und einem Neustart habe ich die aktuelle Version der xkbmap von Neo installiert. Dann noch einmal ein Neustart, um sicher zu gehen.

Beide Systeme – also 64 wie auch 32 bit – lassen sich einwandfrei starten. Ich kann in beiden Systemen alle Tasten und Ebenen verwenden.

Was habt Ihr, die Ihr Probleme habt, anders gemacht?

Ich habe noch keine Updates eingespielt (liegt es vielleicht daran?).

comment:6 als Antwort auf: ↑ 5 Geändert vor 9 Jahren durch erik

Replying to erik:

Ich habe gerade nochmal zwei Systeme installiert: Ein Ubuntu 10.04 32 bit-System und ein Ubuntu 10.04 64 bit-System.

Was ich noch vergessen habe zu sagen: Die beiden Installationen habe ich in VirtualBox gemacht. Ein weiteres 64 bit-System habe ich aber auch auf meinem echten Rechner installiert. Ein System mit Onboard-Grafik und die den freien ATI-Treiber verwendet.

comment:7 Geändert vor 9 Jahren durch frank

Wie bereits von Karl (siehe http://lists.neo-layout.org/pipermail/diskussion/2010-May/017044.html) erwähnt liegt es möglicherweise daran, dass mehrere Layouts zur Auswahl stehen. Schau mal bei System → Einstellungen → Tastatur → Belegungen nach:

  • Steht dort nur Neo 2?
  • Ändert sich etwas, wenn du ein Layout hinzufügst?
  • Ändert sich etwas, wenn du die automatische Anmeldung deaktivierst, also beim Hochfahren immer Name und Passwort eingeben musst?
  • Und wie sieht’s aus, wenn du bei der Installation Qwertz auswählst und erst im Nachhinein Neo? Wenn du Neo im Nachhinein nur hinzufügst oder Qwertz damit ganz ersetzt?

comment:8 als Antwort auf: ↑ 5 ; Antwort: Geändert vor 9 Jahren durch dennis

Replying to erik:

Außerdem beim Erstellen des Benutzers unten „Automatisch anmelden“ angeklickt.
[…]
Was habt Ihr, die Ihr Probleme habt, anders gemacht?

Ich glaube, genau da liegt der Fehler: Ich hatte in diesem Schritt nicht »automatisch anmelden«, sondern »Benutzer muss das Password eingeben« (war glaube die zweite Möglichkeit, aber nicht die verschlüsselte Variante) ausgewählt. Das Problem ist ja, dass sich der Anmeldebildschirm GDM ständig neu lädt und nicht richtig hochfährt, aber genau den (und damit das Problem) hast Du durch das »automatische Anmelden« in Deinen beiden Testinstallationen ausgelassen/übersprungen.

comment:9 Geändert vor 9 Jahren durch stephan

Könnte das nochmal mit r2309 getestet werden?

comment:10 Antwort: Geändert vor 9 Jahren durch peter eberhard

Mit r2309 funktioniert es bei mir sowohl mit automatischer Anmeldung als auch ohne. Ich habe allerdings Ubuntu gerade eben erst installiert und hatte deswegen nie Probleme.

Mal sehen, ob es bei Dennis jetzt auch funktioniert?

comment:11 als Antwort auf: ↑ 10 Geändert vor 9 Jahren durch dennis

Replying to peter eberhard:

Mal sehen, ob es bei Dennis jetzt auch funktioniert?

Hiermit bestätigt, mit der neuesten SVN-Version tritt der Fehler unter dem UNR nicht mehr auf :).

comment:12 als Antwort auf: ↑ 8 Geändert vor 9 Jahren durch erik

Replying to dennis:

Replying to erik:

Außerdem beim Erstellen des Benutzers unten „Automatisch anmelden“ angeklickt.
[…]
Was habt Ihr, die Ihr Probleme habt, anders gemacht?

Ich glaube, genau da liegt der Fehler: Ich hatte in diesem Schritt nicht »automatisch anmelden«, sondern »Benutzer muss das Password eingeben«

Das ist es. Jetzt habe ich endlich auch Abstürze. Zum verwende ich eigentlich Fedora, da gibt es keine Probleme.

Mit der neuen Version r2309 von Stephan funktioniert es aber dann doch wieder. Also, Problem gelöst. Können das bitte noch ein paar andere bestätigen, dann kann das Ticket geschlossen werden.

comment:13 Geändert vor 9 Jahren durch Björn Seifert

  • Lösung auf fixed gesetzt
  • Status von new nach closed geändert

Bei meinem seit Januar installierten Ubuntu 10.04 läuft r2309 nun einwandfrei. ¡Danke Stephan!

comment:14 Antwort: Geändert vor 9 Jahren durch janosch_maier@…

  • Lösung fixed gelöscht
  • Status von closed nach reopened geändert

Ich kann das ganze leider _nicht_ bestätigen.

Allerdings habe ich zusätzlich zu Neo noch Querty als zweites Layout eingsetellt. Ich versuche morgen eine VM aufzusetzen, dass ich das ganze noch ausführlich testen kann. Hier auf meinem Produktivsystem wird mir das langsam zu heikel.

comment:15 als Antwort auf: ↑ 14 ; Antwort: Geändert vor 9 Jahren durch Björn Seifert

Replying to janosch_maier@…:

Allerdings habe ich zusätzlich zu Neo noch Querty als zweites Layout eingsetellt.

Mal zum Testen habe ich als zweites Layout Qwertz (wieso hast du U und W getauscht? ;-)) und später sogar Arabisch hinzugenommen und schalte friedlich mit der linken Win-Taste um – keine Probleme bei mir … Das einzige, was nicht funktioniert ist gnome-Terminal Strg-C zu senden, nachdem ich von Neo auf Qwertz umgestellt habe, es wird zum Strg-Ä. Aber das ist ein anderes Problem. xterm kann das besser.

comment:16 als Antwort auf: ↑ 15 ; Antwort: Geändert vor 9 Jahren durch anonym

Bin jetzt endlich dazu gekommen, das ganze in einer virtuellen Maschine zu testen, und der Fehler ist dort auch verschwunden.

Werde das ganze heute Abend nochmal direkt an meinem Laptop einspielen, und bin gespannt, was passiert.

comment:17 als Antwort auf: ↑ 16 Geändert vor 9 Jahren durch Björn Seifert

Replying to anonymous:

Bin jetzt …

Werde das ganze …

Wenn man jetzt noch wüsste, wer du bist …

comment:18 Geändert vor 9 Jahren durch janosch_maier@…

Ich bitte um Entschuldigung. Das Feld mit der Mail-Adresse ist bei einem Neu-Laden der Seite gellert worden, ohne, dass ich es gemerkt habe.

Janosch

comment:19 Geändert vor 9 Jahren durch janosch_maier@…

  • Lösung auf fixed gesetzt
  • Status von reopened nach closed geändert

Es geht nun.
Jetzt würde mich nur noch interessieren, warum das vor ein paar Tagen, als ich es genau so probiert hatte, nicht der Fall war.

Kommentar hinzufügen

Ticket ändern

Eigenschaften ändern
<Autor-Feld>
Aktion
als closed .
Der Status der Lösung wird gelöscht. Der nächste Status wird 'reopened' sein.
Autor


E-Mail-Adresse und Benutzername können in den Einstellungen gespeichert werden.

 
Hinweis: Hilfe zur Verwendung von Tickets finden Sie in TracTickets.